1. IMPORTANT : Nouvelles mesures de sécurité - 2. Règles pour obtenir de l'aide dans les forums de support - 3. Restrictions des droits pour le groupe "Support suspendu"

Il est obligatoire de respecter les Règles de MyBB.fr : Version abrégée ou Version complète pour obtenir du support sur nos forums.

Les membres ayant un site/forum contrevenant aux règles de MyBB.support seront placés dans le groupe "Support suspendu" et ne bénéficieront plus du support du staff. Nous recommandons aux autres membres d'agir de même. Il ne s'agit pas d'un bannissement, le membre retrouvera son statut "normal" dès que sa situation sera conforme aux règles.

Nouveau : un Wiki en français : plus de détails.
Avant de soumettre votre problème, consultez-le, ainsi que la FAQ, sans oublier le moteur de recherche interne.


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] 2 petits soucis
Tags » résolu, petits, soucis
01-08-2010, 9:58, (This post was last modified: 21-11-2010, 1:02 by Seor.)
#1
[Résolu] 2 petits soucis
Bonjour,

je vous soumets 2 soucis sur lesquels je bute depuis un bout de temps.

Version 1.4.11 de Board.

Le premier est accessoire mais me trouble quand même: Lorsque je décide de répondre ou d'envoyer un message privé il apparaît très rapidement une case à cocher CCI (copie conforme) et puis elle disparaît.
J'ai cherché partout dans le panneau d'administration, rien trouvé.

Où s'active cette cette fonction svp ?

Deuxième point:

Je n'ai pas trouvé de tuto pour upgrader ma version de board en 1.4.13. Peut être n'aie je certainement pas bien regardé mais je ne veux pas faire une boulette qui coincerait mon forum.
J'ai bien vu les explications sur le site de MyBB mais mon anglais étant approximatif je suis inquiet.
Si une âme charitable pouvait me donner un lien j'en serais très reconnaissant.

Je précise que je suis un peu coincé car c'était un expert qui avait fait l'installation initiale et il n'est plus actif depuis un moment.

Merci par avance.
Reply
01-08-2010, 11:08,
#2
RE: 2 petits soucis
Salut,

1 Jamais entendu parler de la possibilité d'ajouter un destinataire en Cci dans les MP.

2. Pour une mise à jour vers 1.4.13

a) Attention: Avant toute chose, fais un backup de ta base et de tes fichiers ! Ça te permettre de revenir à la situation initiale en cas de souci.

b) Récupère d'abord le pack complet fr/en ici :
http://www.mybb.fr/showthread.php?tid=2557

c) Uploade les fichiers en écrasant ceux présents

d) Lance dans ton navigateur :
/url_de_ton_forum/install/upgrade.php

Choisis bien 1.4.11 à l'étape "version actuelle"...

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
01-08-2010, 11:25,
#3
RE: 2 petits soucis
Merci Spyto pour cette réponse rapide.

Pour le point 1 si je peux j'essaye de faire un screen et je le poste...
Bonjour Spyto,

Heuuu désolé de revenir sur cette question que j'avais laissé de coté pour cause de taf chargé.

J'ai fait le début à savoir téléchargement et décompression.
J'ai imprimé ta page d'aide pour upgrade.

La peur que j'ai est de supprimer les fichiers existants par exemple dans le dossier "avatars" pour ne citer que celui là.
Va-t-il considérer que ce dossier n'est pas vide et qu'il va conserver le contenu?

c'est ballot mais c'est un point qui me bloque !!!! Sad
Reply
30-08-2010, 16:25,
#4
RE: 2 petits soucis
Salut,
Tu ne perdras rien; Mais comme la dit Spyto sauvegarde d'abord.

Bon hébergeur pas cher PlanetHoster
[Image: 1239239462.ico]

Reply
30-08-2010, 23:40,
#5
RE: 2 petits soucis
Ok Magic, je fais l'opération et viendrai respirer ici après le succès Wink
Bon, je respire un peu mieux... Cela ne s'est pas mal passé si ce n'est que le template que j'utilisais a disparu au profit d'un truc inconnu.
J'utilisais le Afresh Midnight qui est bien toujours sélectionné par défaut mais il n'a plus la même apparence que l'ancien.

Si quelqu'un a une idée...
Reply
10-11-2010, 23:57,
#6
RE: 2 petits soucis
@ Spyto:

Voici en fin le screen de la preuve que j'attendais lorsque j'ai parlé plus haut de ce fameux champ CCI dans les MP.

Je précise de suite que cela apparait mais ça disparait très vite après:

[Image: forumcci2.jpg]

Le thème de mon forum est Afresh Midnight.

Si une idée germait.... Smile

A bientôt.
Reply
20-11-2010, 13:02,
#7
RE: 2 petits soucis
UP Smile
Reply
20-11-2010, 16:26,
#8
RE: 2 petits soucis
Oui, il y a un truc qui cloche, mais pour l'instant je ne trouve pas !...

Si on passe le forum en 'english', ça s'affiche.
Si on le met en French, ça ne s'affiche pas !
Donc, ça vient des fichiers de langue, forcément .
Et plus précisément de private.lang.php.
J'ai beau comparer tot semble bon....

En french, le code source affiche bien le JavaScript :
PHP Code:
<script type="text/javascript">
    <!--
        
document.write('(<a href="#" onclick="showBcc(); return false;" title="Afficher la zone de saisie CCI vous permettant d'envoyer des copies carbone invisibles aux autres utilisateurs.">CCI<\/a>)');
    // -->
    </script> 

Eurêka, j'ai compris !!!
Il faut échapper l'apostrophe de la chaîne :
PHP Code:
$l['compose_bcc_show_title'] = "Afficher la zone de saisie CCI vous permettant d'envoyer des copies carbone invisibles aux autres utilisateurs."
ligne 31 du fichier langue private.lang.php, malgré la présence des guillemets doubles !
(eh oui, c'est utilisé par du JavaScript ! Et quand on est le nez dans la traduction du fichier PHP on n'y pense pas...)

Donc ligne à remplacer par :
PHP Code:
$l['compose_bcc_show_title'] = "Afficher la zone de saisie CCI vous permettant d\'envoyer des copies carbone invisibles aux autres utilisateurs."
D'ailleurs il faudra qu'on revoie toutes les chaines utilisées par le JavaScript pour faire de même.

S'il y a des amateurs pour lister les variables utilisées par JS, qu'ils n'hésitent pas à le faire !!!

Ci-joint le fichier corrigé à remplacer dans /inc/languages/french

.php   private.lang.php (Size: 12.23 KB / Downloads: 21)
Et là tu auras le lien CCI qui fait apparaître l'option CCI.

Merci pour le signalement, jamais je n'y aurais pensé ! Wink Tongue
Je m'en vais mettre à jour les archives à télécharger...

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
20-11-2010, 23:36,
#9
RE: 2 petits soucis
Haaaaa chouette !!! I am happy !!!! Bravo Spyto pour avoir débusquer l'apostrophe coupable !!!

Ravi que cela puisse servir à tout le monde à l'avenir !
Reply




Users browsing this thread: 1 Guest(s)

Contact Us | MyBB.support | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication
 Translation utility provided by Regentronique