1. IMPORTANT : Nouvelles mesures de sécurité - 2. Règles pour obtenir de l'aide dans les forums de support - 3. Restrictions des droits pour le groupe "Support suspendu"

Il est obligatoire de respecter les Règles de MyBB.fr : Version abrégée ou Version complète pour obtenir du support sur nos forums.

Les membres ayant un site/forum contrevenant aux règles de MyBB.support seront placés dans le groupe "Support suspendu" et ne bénéficieront plus du support du staff. Nous recommandons aux autres membres d'agir de même. Il ne s'agit pas d'un bannissement, le membre retrouvera son statut "normal" dès que sa situation sera conforme aux règles.

Nouveau : un Wiki en français : plus de détails.
Avant de soumettre votre problème, consultez-le, ainsi que la FAQ, sans oublier le moteur de recherche interne.


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rapports concernant la v1.6
Tags » rapports, concernant, v16
13-08-2010, 12:58, (This post was last modified: 13-08-2010, 14:46 by spyto.)
#21
RE: Rapports concernant la v1.6
Salut,

Tout d'abord, merci beaucoup pour ce gros travail de relecture/correction.
Un regard extérieur est très suvent bénéfique. A force d'avoir le nez dans le guidon, on ne voit plus la route. Wink

Globalement je suis à peu près d'accord sur tout.
global.lang.php => OK, fait
helpdocs.lang.php => OK, fait
member.lang.php=> OK, fait (pourtant j'avais échappé les apostrophes dans la v1.4 ! Oublié de reporter ici effectivement)
moderation.lang.php => OK, fait
newreply.lang.php => OK, fait
reputation.lang.php => OK, fait
usercp.lang.php => OK, fait
config_settings.lang.php => OK, fait (pas pris le temps de contrôler, mais ce doit être bon...)
+ Reporté dans /install/resources/settings.xml

Dossier admin :

config_thread_prefixes.lang.php => OK, fait
global.lang.php => j'ai laissé :
Ligne 292
PHP Code:
//$l['login_field_width'] = "0"; 
comme dans le fichier anglais, libre à l'utilisateur de le modifer éventuellement
home_credits.lang.php => OK, fait
home_dashboard.lang.php => OK, fait
home_preferences.lang.php => OK, plus "français", fait
style_themes.lang.php => OK, fait
tools_adminlog.lang.php => => fait, mais pour moi c'est la ligne 230 !? Me manquerait-il une ligne ? A voir..
tools_cache.lang.php => OK pour ta proposition, fait
tools_file_verification.lang.php => OK fait (note : sûrement pas un traducteur en lgne, je n'utilise pas ça ! Juste des mots anglais restés et un excès de fatigue. Shy
tools_mailerrors.lang.php => OK, fait
tools_tasks.lang.php => OK fait, bien que "Gestion de tâches" ou "Gestion des tâches" me semble identique...
user_banning.lang.php => OK, fait
user_mass_mail.lang.php => OK, fait

Dossier install :

Pour l'install, je sais qu'il y a plein de trucs à revoir, j'étais loin d'avoir tout relu/revu...
Pour les encodages, j'étais en train de mettre les entités nommées.

Par contre, là où je ne suis pas d'accord, c'est de conserver le fichier "settings.xml" anglais.
A l'installation c'est ce fichier qui est lu et inscrit dans la base et pas mal de variables sont lues d'abord dans la base avant le fichier "config_settings.lang.php".
Donc je conserve le fichier français... c'est d'ailleurs grâce à lui que j'ai créé à l'aide d'un script le fichier "config_settings.lang.php" complet !). Ce serait donc une aberration de remettre l'anglais !

Bon, je pense avoir fait le tour, c'était effectivement long !

Avant de mettre à jour l'archive téléchargeable, j'aimerais faire une comparaison fichier par fichier avec ta version pour voir si je n'ai rien oublié !
Aussi si tu pouvais joindre un zip uniquement de tes fichiers de langue ?

Merci encore pour ce travail remarquable.

PS : Pour les espaces en trop, ce n'est pas critique puisque l'affichage en HTML n'en retiendra qu'un !


Edit
Quant au fichier /install/index.php, je ne suis pas persuadé qu'il faille encoder en entités nommées les lignes de commentaire servant à récrire le fichier /inc/config.php (à partir de la ligne 1111).
Ou alors il faut tout encoder et ti n'as encodé que les à

Idem pour upgrade17.php

Le fichier mysql_db_inserts.php, j'avais tout simplement oublié de le traduire...

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
13-08-2010, 14:49,
#22
RE: Rapports concernant la v1.6
spyto Wrote:Dossier admin :

global.lang.php => j'ai laissé :
Ligne 292
PHP Code:
//$l['login_field_width'] = "0"; 
comme dans le fichier anglais, libre à l'utilisateur de le modifer éventuellement

tools_adminlog.lang.php => => fait, mais pour moi c'est la ligne 230 !? Me manquerait-il une ligne ? A voir..
tools_file_verification.lang.php => OK fait (note : sûrement pas un traducteur en lgne, je n'utilise pas ça ! Juste des mots anglais restés et un excès de fatigue. Shy
- Pour le "login_field_width" je pense que MyBB a fait exprès de le laisser pour changer en fonction de la langue et étant donné que nom d'utilisateur dépasse (ce qui ne faisait pas en 1.4) il serait peut-être plus bénéfique de le laisser. Enfin c'est à toi de voir Wink

- La ligne c'est possible car pour comparer les fichiers de anglais à français j'ai laisser les lignes vides au même endroit que dans les fichiers anglais pour voir si tu n'avais oublié aucune ligne, enfin je sais pas si tu vois ce que je veut dire.

- Pour le traducteur je sais bien mais je ne sais pas où vous en êtes au niveau de l'équipe et si tu avais recruté d'autres modérateurs qui serait susceptibles d'avoir utilisaient un traducteur en ligne. Et je disait bien une ressemblance x)

spyto Wrote:Dossier install :

Pour l'install, je sais qu'il y a plein de trucs à revoir, j'étais loin d'avoir tout relu/revu...
Pour les encodages, j'étais en train de mettre les entités nommées.

Par contre, là où je ne suis pas d'accord, c'est de conserver le fichier "settings.xml" anglais.
A l'installation c'est ce fichier qui est lu et inscrit dans la base et pas mal de variables sont lues d'abord dans la base avant le fichier "config_settings.lang.php".
Donc je conserve le fichier français... c'est d'ailleurs grâce à lui que j'ai créé à l'aide d'un script le fichier "config_settings.lang.php" complet !). Ce serait donc une aberration de remettre l'anglais !
Pas de soucis c'était juste une suggestion Wink.
Concernant les fichiers d'installation je peut t'aider si tu le veux en les comparant aussi un à un car j'ai été plus bref la dessus (upgrade14.php, upgrade15.php, upgrade16.php, upgrade17.php, language.lang.php, mysql_inserts.php et des petites bidouilles par ci par là mais pas aussi rigoureusement que les fichiers de langues car j'étais un peu fatigué ^^.

spyto Wrote:Bon, je pense avoir fait le tour, c'était effectivement long !

Avant de mettre à jour l'archive téléchargeable, j'aimerais faire une comparaison fichier par fichier avec ta version pour voir si je n'ai rien oublié !
Aussi si tu pouvais joindre un zip uniquement de tes fichiers de langue ?

Merci encore pour ce travail remarquable.
Je te joint ça Wink

spyto Wrote:PS : Pour les espaces en trop, ce n'est pas critique puisque l'affichage en HTML n'en retiendra qu'un !
Je suis juste passé devant donc j'ai remarqué mais en effet l'HTML ne prend qu'un espace à moins de rajouter " " mais bon il doit y en avoir pleins d'autres qui traînent par là même si j'ai été très rigoureux en vérifiant, mais effectivement ce n'est pas bien grave.

spyto Wrote:
Edit
Quant au fichier /install/index.php, je ne suis pas persuadé qu'il faille encoder en entités nommées les lignes de commentaire servant à récrire le fichier /inc/config.php (à partir de la ligne 1111).
Ou alors il faut tout encoder et ti n'as encodé que les à
Là en fait j'ai hésité parce que j'ai vu que tu avais encodé certaines parties et laissé les entités HTML sur d'autres donc faudrait vérifier. Mais je ne sait pas si le php quand il insère dans un fichier prend en compte les entités HTML ?

Voilà,
@+
et65.


Attached Files
.zip   french_et65.zip (Size: 172.76 KB / Downloads: 3)
Reply
13-08-2010, 17:40,
#23
RE: Rapports concernant la v1.6
Re,

Voilà, après quelques heures d'effort intense et soutenu, j'ai donc fait un compare de tes fichiers avec les miens, non seulement pour le dossier langage mais aussi pour /install.

Je te mets en PJ les deux fichiers de comparaison (à gauche mes fichiers, à droite les tiens). Tu te souviens de la structure ?

Tu verras que dans les fichiers de langue, il y a peu de différences :

Quant au dossier /install, j'ai exclu de la comparaison 'settings.xml' puisque tu as mis la version anglaise et 'lock'

Cependant j'ai corrigé 'settings.xml' français et j'ai reconstruit en conséquence config_settings.lang.php (fr)

Je m'en vais mettre à jour les deux archives et les uploader.
Je considère maintenant qu'ils sont pratiquement finalisés... ou presque ! Non ?

Merci pour ce formidable coup de main !

@+
Spyto


Attached Files
.htm   language_compare.htm (Size: 64.1 KB / Downloads: 4)
.htm   install_compare.htm (Size: 42.82 KB / Downloads: 1)

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
13-08-2010, 19:59,
#24
RE: Rapports concernant la v1.6
spyto Wrote:Re,

Voilà, après quelques heures d'effort intense et soutenu, j'ai donc fait un compare de tes fichiers avec les miens, non seulement pour le dossier langage mais aussi pour /install.

Je te mets en PJ les deux fichiers de comparaison (à gauche mes fichiers, à droite les tiens). Tu te souviens de la structure ?

Tu verras que dans les fichiers de langue, il y a peu de différences :

Quant au dossier /install, j'ai exclu de la comparaison 'settings.xml' puisque tu as mis la version anglaise et 'lock'

Cependant j'ai corrigé 'settings.xml' français et j'ai reconstruit en conséquence config_settings.lang.php (fr)

Je m'en vais mettre à jour les deux archives et les uploader.
Je considère maintenant qu'ils sont pratiquement finalisés... ou presque ! Non ?

Merci pour ce formidable coup de main !

@+
Spyto

Re,
Logiquement oui,
je vais m'attaquer de plus près à l'install ce soir peut-être et je te passerai mon compte-rendu mais oui en ce qui concerne la stabilité pour moi c'est bon Wink

Et sinon pour le coup de main avec plaisir c'est la moindre des choses Wink

@+
et65
Reply
13-08-2010, 23:15, (This post was last modified: 14-08-2010, 0:11 by et65.)
#25
RE: Rapports concernant la v1.6
Je viens de regarder ton pack, tu as toujours laissé le mélange entités/caractères spéciaux dans la partie config.php de index.php...
EDIT : Je viens de voir d'autres coquilles :
config_settings.lang.php
Ligne 409
PHP Code:
$l['setting_negrep'] = "Permettre notation négative"
par
PHP Code:
$l['setting_negrep'] = "Permettre la notation négative"

Ligne 411
PHP Code:
$l['setting_multirep_desc'] = "Les utilisateurs peuvent-ils donner de multiples notations au même utilisateur ?<br />Note: N'affecte pas la réputation \"Message\""
par
PHP Code:
$l['setting_multirep_desc'] = "Les utilisateurs peuvent-ils donner de multiples notations au même utilisateur ?<br />Note : n'affecte pas la réputation \"Message\"."

Ligne 416
PHP Code:
$l['setting_repsperpage_desc'] = "Vous pouvez entrer ici le nombre de commentaires de réputation à afficher par page dans le système de réputation"
par
PHP Code:
$l['setting_repsperpage_desc'] = "Vous pouvez entrer ici le nombre de commentaires de réputation à afficher par page dans le système de réputation."
C'est qu'un détail mais bon les autres ont des points ^^

Ligne 418
PHP Code:
$l['setting_maxreplength_desc'] = "The nombre maximal de caractères que peu avoir une notation."
par
PHP Code:
$l['setting_maxreplength_desc'] = "Le nombre maximal de caractères que peut avoir une notation."

Voilà :p

EDIT 2 : encore deux petites :p
config_settings.lang.php
Ligne 306
PHP Code:
$l['setting_default_memberlist_order_desc'] = "Sélectionnez l'ordre par défaut à utiliser pour trier la liste des membres.<br />Croissant: A-Z/début-fin<br />Décroissant: Z-A/fin-début"
par
PHP Code:
$l['setting_default_memberlist_order_desc'] = "Sélectionnez l'ordre par défaut à utiliser pour trier la liste des membres.<br />Croissant : A-Z/début-fin<br />Décroissant : Z-A/fin-début"

settings.xml (ca y est pas dans le php)
Ligne 941/942
Code:
ASC=Ascendant
DESC=Descendan]]></optionscode>
par
Code:
ASC=Croissant
DESC=Décroissant]]></optionscode>

EDIT 3 :
Le forum m'affiche "Calendrier par d&eacute;faut" sûrement que l'entité est resté dans "mysql_inserts.php"
Reply
14-08-2010, 10:29,
#26
RE: Rapports concernant la v1.6
et65 Wrote:tu as toujours laissé le mélange entités/caractères spéciaux dans la partie config.php de index.php..
Oui, c'est voulu, je pense que c'est comme ça qu'il faut faire. De toute façon, ça ne touche que des lignes de commentaire. On verra à l'usage.
.
Quote:Je viens de voir d'autres coquilles...
OK, config_settings.lang.php et settiongs.xml corrigés selon ton rapport
Quote:settings.xml (ca y est pas dans le php)
Ligne 941/942
Code:
ASC=Ascendant
DESC=Descendan]]></optionscode>
par
Code:
ASC=Croissant
DESC=Décroissant]]></optionscode>
Corrigé. C'est normal que ce ne soit pas dans le PHP. C'est un champ "value". Il est donc écrit directement dans la base à l'install.
C'est un exemple précis de la nécessité de traduire aussi le fichier settings.xml. Pour avoir absolument tout en fr dans l'ACP.
Quote:Le forum m'affiche "Calendrier par d&eacute;faut" sûrement que l'entité est resté dans "mysql_inserts.php"
Normal, j'ai bêtement out encodé en entités nommées or le fichier est enregistré en ANSI !
Je l'ai donc converti en UTF-8 sans BOM, je pense que c'est la solution la plus rationnelle.

Voilà, j'ai updaté les deux archives.

Merci beaucoup encore !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
14-08-2010, 13:56,
#27
RE: Rapports concernant la v1.6
spyto Wrote:
et65 Wrote:tu as toujours laissé le mélange entités/caractères spéciaux dans la partie config.php de index.php..
Oui, c'est voulu, je pense que c'est comme ça qu'il faut faire. De toute façon, ça ne touche que des lignes de commentaire. On verra à l'usage.
.
Quote:Je viens de voir d'autres coquilles...
OK, config_settings.lang.php et settiongs.xml corrigés selon ton rapport
Quote:settings.xml (ca y est pas dans le php)
Ligne 941/942
Code:
ASC=Ascendant
DESC=Descendan]]></optionscode>
par
Code:
ASC=Croissant
DESC=Décroissant]]></optionscode>
Corrigé. C'est normal que ce ne soit pas dans le PHP. C'est un champ "value". Il est donc écrit directement dans la base à l'install.
C'est un exemple précis de la nécessité de traduire aussi le fichier settings.xml. Pour avoir absolument tout en fr dans l'ACP.
Quote:Le forum m'affiche "Calendrier par d&eacute;faut" sûrement que l'entité est resté dans "mysql_inserts.php"
Normal, j'ai bêtement out encodé en entités nommées or le fichier est enregistré en ANSI !
Je l'ai donc converti en UTF-8 sans BOM, je pense que c'est la solution la plus rationnelle.

Voilà, j'ai updaté les deux archives.

Merci beaucoup encore !

Y a pas de soucis je te tiens au courant si je tombe sur autre chose car là je corrige avec un forum sous les yeux et non un vulgaire fichier php c'est parfois mieux :p
Reply
15-08-2010, 20:54,
#28
RE: Rapports concernant la v1.6
salut

petite correction sur cette capture , un "e" en trop

[Image: bug_3_10.jpg]

merci

@+
Reply
15-08-2010, 20:58,
#29
RE: Rapports concernant la v1.6
re,

j'ai un probleme avec la section configuration admin , j'ai des "�"

[Image: bug_fo10.jpg]

merci

@+
Reply
15-08-2010, 21:17,
#30
RE: Rapports concernant la v1.6
re,

autre probleme , voici une capture

[Image: bug_2_10.jpg]

voici le lien de la croix : /forum/images/theme1/arrow_down.gif

je vois pas pourquoi cette icone serait là , bizarre non ?

merci

@+
Reply
15-08-2010, 21:19, (This post was last modified: 15-08-2010, 21:25 by spyto.)
#31
RE: Rapports concernant la v1.6
Quote:petite correction sur cette capture , un "e" en trop
OK, merci, c'est dans le fichier french/admin/user_users.lang.php
Corrigé, archive mise à jour.

Quote:j'ai un probleme avec la section configuration admin , j'ai des "�"
Par contre là je ne comprends pas...
Le fichier contenant les chaînes utilisées dans les paramètres (french/admin/config_settings.lang) est bien encodé en UTF-8 !

Tu as fait une install "neuve", ou un upgrade ?

Quote:autre probleme , voici une capture
C'est quoi ce sous-dossier /theme1 dans /images ? Je suppose que tu as installé un thème ?
L'image "arrow_down.gif" est à la racine de images !
Le lien (pour le thèmes base) devrait être : /images/arrow_down.gif

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
15-08-2010, 22:06,
#32
RE: Rapports concernant la v1.6
Quote:j'ai un probleme avec la section configuration admin , j'ai des "�"
Par contre là je ne comprends pas...
Le fichier contenant les chaînes utilisées dans les paramètres (french/admin/config_settings.lang) est bien encodé en UTF-8 !

Tu as fait une install "neuve", ou un upgrade ?

--------------------------------------------------------------------

re, j'ai encodé en UTF-8 ( sans BOM ) et je n'ai plus les "�"

--------------------------------------------------------------------

Quote:autre probleme , voici une capture
C'est quoi ce sous-dossier /theme1 dans /images ? Je suppose que tu as installé un thème ?
L'image "arrow_down.gif" est à la racine de images !
Le lien (pour le thèmes base) devrait être : /images/arrow_down.gif
[/quote]

--------------------------------------------------------------------

re , j'ai placé le fichier arrow_down.gif sur images/ , j'ai maintenant le arrow_down visible , il me permet d'accedé aux pages suivante par clic dessus

merci spyto , et merci pour ton travail sur la version fr

@+
Reply
15-08-2010, 22:37,
#33
RE: Rapports concernant la v1.6
Effectivement config_settings.lang.php était en UTF-8 avec BOM. Shy
Je me demande bien pourquoi !?
Ce truc traîne depuis la v1.4.12 et je ne m'en étais pas aperçu.
Sans doute parce que personnellement, avec ou sans BOM, ça ne posait aucun problème... et que personne n'avait nopn plus rencontré de problèmes, à priori ?

Par contre, ton sous-dossier /theme1 ne devrait pas exister ! A moins qu'un thème importé l'ait créé ?
Il existe sur le FTP ?
Si non, comment expliques-tu ce lien erroné ?

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
15-08-2010, 22:47,
#34
RE: Rapports concernant la v1.6
re,

oui , j'ai un theme sur le FTP sous le nom theme1

la version MyBB 1.6 est sur serveur en ligne , pas sur un local et malgré les petits bugs ou erreur , elle fonctionne tres bien dans l'ensemble.

merci spyto

@+
Reply
15-08-2010, 22:59,
#35
RE: Rapports concernant la v1.6
De rien... Wink

C'est sympa de tester et c'est encore mieux en ligne !
Merci de tes rapports.

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
20-08-2010, 17:26,
#36
RE: Rapports concernant la v1.6
salut

j'ai découvert que dans certainent parties de l'admin ( configuration : parametres ) les menus déroulants sont en englais , voici une capture :

[Image: captur11.jpg]

avez vous la meme chose ?

merci

@+
Reply
20-08-2010, 18:50,
#37
RE: Rapports concernant la v1.6
Non, je l'ai bien français !

Et j'ai vérifié /install/settings.xml, il contient bien :
Code:
<setting name="regtype">
            <title>Méthode d'enregistrement</title>
            <description><![CDATA[Veuillez sélectionner la méthode à utiliser quand les utilisateurs s'enregistrent.]]></description>
            <disporder>2</disporder>
            <optionscode><![CDATA[select
instant=Activation immédiate
verify=Vérification par envoi d'email
randompass=Envoyer un mot de passe aléatoire
admin=Activation par administrateur]]></optionscode>
            <settingvalue><![CDATA[verify]]></settingvalue>
            <isdefault>1</isdefault>
            <helpkey></helpkey>
        </setting>
ce qui signifie que ces phrases doivent s'inscrire en français dans la base à l'installation !

La présence des phrases anglaises pourrait s'expliquer si tu as fait la première installation en anglais, suivie d'une mise à jour fr, ou si tu n'utilises que le Langpack.

Je ne vois pas autrement, car si tu installes avec le pack bilingue complet, il est impossible d'avoir ça !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
20-08-2010, 20:18,
#38
RE: Rapports concernant la v1.6
re,

oui , j'ai commencé par la version anglaise , donc ceci explique cela lol

est-ce qu'il faut que je fasse un upgrade de ta version fr pour résoudre ce petit souci ?

merci spyto

@+
Reply
20-08-2010, 22:37,
#39
RE: Rapports concernant la v1.6
Oui tu peux toujours essayer.. ça devrait, en principe réécrire la BD avec les bonnes valeurs.
Mais je n'en suis pas absolument certain.
Je pense que tu ne risques rien de tenter.
(fais quand même un petit backup de la BD au cas où...)

Sinon, il te faudra bidouiller manuellement ta BD.

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
21-08-2010, 2:05,
#40
RE: Rapports concernant la v1.6
Bonjour / bonsoir =)

je tente d'installer mybb et j'obtiens cette erreur :

Quote:Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez.131/dedicatel/www/forum/inc/class_error.php on line 51

la fameuse ligne 51 :

Quote:public $error_types = array(

voilà et je ne sais pas quoi faire de cette erreur ne sachant pas si elle provient de mybb en lui même ou de la traduction.

=)
Reply




Users browsing this thread: 1 Guest(s)

Contact Us | MyBB.support | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication
 Translation utility provided by Regentronique