1. IMPORTANT : Nouvelles mesures de sécurité - 2. Règles pour obtenir de l'aide dans les forums de support - 3. Restrictions des droits pour le groupe "Support suspendu"

Il est obligatoire de respecter les Règles de MyBB.fr : Version abrégée ou Version complète pour obtenir du support sur nos forums.

Les membres ayant un site/forum contrevenant aux règles de MyBB.support seront placés dans le groupe "Support suspendu" et ne bénéficieront plus du support du staff. Nous recommandons aux autres membres d'agir de même. Il ne s'agit pas d'un bannissement, le membre retrouvera son statut "normal" dès que sa situation sera conforme aux règles.

Nouveau : un Wiki en français : plus de détails.
Avant de soumettre votre problème, consultez-le, ainsi que la FAQ, sans oublier le moteur de recherche interne.


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Packs MyBB 1.6.6 [maj 14-02-2012]
Tags » packs, mybb, 166, 10-02-2012, maj, 14-02-2012
10-02-2012, 23:59, (This post was last modified: 14-02-2012, 16:56 by spyto.)
#1
Packs MyBB 1.6.6 [maj 14-02-2012]
Edit 14-02-2012 15:50
Voilà j'ai corrigé, recréé les deux archives. Les lien de téléchargement sont de nouveau opérationnels.
Ça m'a pris toute la matinée... Merci mybb.com Sad

Je demande aux membres ayant téléchargé l'archive avant aujourd'hui (14-02-12 10:30) de bien vouloir m'excuser de la mise à disposition de ces mauvais packs, même si la responsabilité en incombe à mybb.com qui avait fourni une mauvaise archive (voir explications plus bas).

Et comme toujours, je le dis à chaque distribution, testez sur des forums non importants dans les premiers jours/semaines !!!
(conseil encore renforcé cette fois-ci. Il m'aura fallu des heures de comparaisons de fichiers, s'il n'y a pas d'erreur ce sera un miracle)

Merci à tous ceux qui testeront et feront des rapports de bugs.

Pour ma part, j'ai testé une install "neuve", une maj depuis 1.6.4 et 1.6.5, ça me semble correct.

Note : de toute ma longue histoire de traduction de mybb, c'est la première fois qu'un telle bourde est commise par les développeurs de mybb.com.
Un ou deux fichiers, c'est déjà arrivé, mais mettre des fichiers de la 1.6.7 (en développement) dans l'archive 1.6.6 fournie publiquement, il faut le voir pour le croire Faut quand même le faire ! Tongue

14-02-12 10:30 - DERNIÈRE MINUTE : N’utilisez ce pack si vous l'avez téléchargé, il est erroné !

Et ce n'est pas de ma faute ! En effet, lors de la publication de MyBB 1.6.6 sur le site de mybb.com, les "développeurs" ont par erreur inclus dans ce pack des fichiers de développement de la 1.6.7 !
L'erreur est humaine certes, mais je considère ça comme un manque de sérieux et de professionnalise.
D'autant plus que je n'ai pas vu d'annonce officielle qui attire l'attention sur ce problème sur l'index. de mybb.com.

C'est cfillion qui me l'a signalé, suite à un rapport de bug de Alexoune001, ici :
http://www.mybb.fr/thread-2813-post-29745.html#pid29745

Entretemps ils ont corrigé le pack anglais, mais bob... il me reste tout à refaire ! Et il y a des quantités de fichiers qui ne correspondent pas.

JE DOIS TOUT REFAIRE... sans en être responsable. C'est vraiment infernal. Ce n'est pas la première "bévue" là-bas, mais cette fois elle est de taille !

Un peu de patience, je reconstruis tout.
Merci pour votre compréhension...



MyBB 1.6.6 est sorti aujourd’hui sur mybb.com.
J'ai fait de mon mieux pour créer le plus rapidement possisble mes packs habituels.

J'avais le choix de farfouiller tout seul dans mon coin à la recherche de bugs avant de le publier.
Si vous êtes nombreux à tester (pas sur un forum de production pour l'instant !...), la recherche d'éventuels bugs/coquilles n'en sera que plus rapide !
Merci à ceux qui m'aideront à les dénicher.
Postez vos rapports dans le forum prévu à cet effet

Pour ma part j'ai testé une mise à jour et une réinstallation en local sans noter de problème particulier....

Que corrige cette version ?

Un problème majeur et 14 vulnérabilités à faible risque ont été corrigés.
Seuls les problèmes listés ci-dessous ont été traités ; une version de maintenance supplémentaire sera disponible avec des corrections générales apportées aux fonctionnalités dans un avenir proche.

Vulnérabilités :
Non critique : Import d'une feuille de style non-CSS (Thçme)
Risque faible: vulnérabillité CSRF dans déconnexion Admin CP (problème #1769)
Risque faible: vulnérabillité CSRF en effaçant un mot de passe stocké (problème #1824)
Risque faible: vulnérabillité CSRF lors de la suppression d'un contact (problème #1825)
Risque faible: vulnérabillité CSRF avec les requêtes de joinyure dans Admin CP (problème #1834)
Risque faible: vulnérabillité CSRF dans l'activation/désactivation des promotions de groupe
Risque faible: vulnérabillité CSRF dans l'éditiion d'utilisateur (Avatar)
Risque faible: vulnérabillité CSRF avec l'acivation d'un utilisateur
Risque faible: vulnérabillité XSS en déplaçant un évènement (Calendrier)
Risque faible: vulnérabillités XSS dans le plugin Akismet
Risque faible: vulnérabillités XSS dans les abonnements de forum (Conf. utilisateur)
Risque faible: vulnérabillité XSS dans les suivis de modérateur
Risque faible: vulnérabillité XSS dans l'édition d'un message
Risque faible: vulnérabillité XSS dans l'édition des annonces

Procédure de mise à jour

Cette fois-ci je n'ai pas créé l'archive "changed_files 1.6.6" car la liste des fichiers modifiés depuis 1.6.5 signalés sur mybb.com est inexacte/incomplète et je n'ai ni le temps, ni l'envie de créer mon propre "diff" pour l'instant !

Donc, quelle que soit votre version, uploadez tous les fichiers en remplaçant les existants..
Il est ensuite indispensable de lancer le script d'upgrade :
url_forum/install/upgrade.php

Télécharger le pack complet fr/en full

Télécharger uniquement le pack de langue dans le cas d'une installation anglaise de 1.6.6 (doc incluse)

Note : je ne traduis plus les fichiers de /inc/datahandlers, ce n'est pas d'une grande utilité !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~




Users browsing this thread: 1 Guest(s)

Contact Us | MyBB.support | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication
 Translation utility provided by Regentronique